Vulnerabilidad en eMule 0.42d

A todos los usuarios de este cliente libre de la red EDonkey nos interesa esta noticia. Según Secunia (en castellano la noticia la refleja Hispasec), se ha descubierto un agujero de seguridad en eMule 0.42d que podría ser explotado por usuarios maliciosos para ejecutar código arbitrario de forma remota. Es posible que afecte a anteriores versiones de eMule y la única forma de protegerse es actualizar a la última versión: eMule 0.42e.
Técnicamente, el bug consiste en la posibilidad de provocar un desbordamiento de pila en la función DecodeBase16(), que es utilizada por el servidor web que integra eMule, así como por su cliente de IRC. La no utilización de estos servicios no libra del problema y al parecer ya hay disponibles herramientas para explotar esta vulnerabilidad de eMule.

Sin categoría